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@ cnes

Logiciel SIG (Système d’Information Géographique)

❖ Système d’information capable d’organiser et de 

présenter des données alphanumériques 

spatialement référencées ainsi que de produire 

des plans et des cartes

En quelques mots

❖ Commencé en 2002

❖ Basé sur GDAL

❖ Open source, sous licence GPL

Fonctionnalités

❖ Affichage ou production de cartes

❖ Analyse des données pour créer une nouvelle information

❖ Acquisition des données

❖ Abstraction ou représentation des éléments choisis

❖ Archivage

Les données géographiques possèdent quatre composantes :

❖ Les données géométriques renvoient à la forme et à la 
localisation des objets ou phénomènes

❖ Les données descriptives (ou attributaires) renvoient à 
l'ensemble des attributs descriptifs des objets et 
phénomènes

❖ Les données de styles renvoient aux paramètres 
d'affichage des objets (type de trait, couleur,...)

❖ Les métadonnées associées, c'est à dire les données 
qui décrivent les données (date d'acquisition, nom du 
propriétaire, méthode d'acquisition, ...)
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Source : http://piece-jointe-carto.developpement-

durable.gouv.fr/NAT002/QGIS/formations/FOAD_PEM_QGIS34/pdf/M01_IntroductionQGIS_papier.pdf



@ cnes

Image raster et vecteur

Raster = grille de pixels organisés en lignes / colonnes

Chaque pixel a des valeurs : 

❖ Données continues : couleur (e.g. RGB), hauteur (e.g. 
MNS), …

❖ Données discrètes : masque (e.g. masque de nuage), 
classe (e.g. classe occupation du sol)

Résolution d’un raster dépend du nombre de pixels qu’il 
contient. Plus il y a de pixels dans une image, meilleure est sa 
résolution et sa qualité visuelle. 

C’est pour cela que plus la résolution du raster est grande, 
plus le fichier raster est lourd.

Exemple de format : TIFF + info de géoréférencement = 
GEOTIFF

Vecteur = dessin vectoriel formé de géométries avec des 
données attributaires

❖ Géométrie : nœuds (des points dans l’espace) et 
formules mathématiques pour calculer les arcs (des 
lignes) qui relient ces nœuds entre eux

❖ Attribut : des méta-données, par exemple l’identifiant 
d’une parcelle dans le cadastre vectoriel

Un vecteur est un objet calculé, il est donc possible de 
zoomer et de dé-zoomer à l’infini sur l’image, sans 
altération de sa qualité visuelle.

La taille d’un vecteur ne dépend pas de la taille des 
géométries (uniquement de leur complexité et des 
données attributaires)

Exemple de format : shapefile, GeoJSON
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Source : https://naturagis.fr/cartographie-sig/difference-vecteur-raster/



@ cnes

Géoréférencement et projection

Géoréférencement = consiste à utiliser des coordonnées 
cartographiques pour affecter un emplacement spatial à 
des entités cartographiques

Pour être adéquate, la description de l'emplacement et de 
la forme des entités nécessite une structure de 
coordonnées permettant de définir les emplacements 
réels. Un système de coordonnées géographiques permet 
d'associer des emplacements géographiques à des 
objets. Exemple : longitude, latitude, altitude

Projection cartographique = processus qui consiste à 
transformer et à représenter sur une surface bidimensionnelle 
(plane) des points situés sur la surface sphérique 
tridimensionnelle de la terre

Ellipsoïde de référence + repère géodésique = 
DATUM ou Système Géodésique de Référence
Exemples : RGF (Référentiel Géodésique Français), WGS84

Afin de représenter cet ellipsoïde sur un plan, on utilise 
différents systèmes de projections : 

❖ conforme de Mercator : conserve les angles mais altère 
les surfaces (cartes militaires, de navigation...)

❖ équivalente de Lambert : conserve les surfaces mais 
altères les angles (cartes politiques)

❖ aphylactique qui altère les angles et les surfaces

Exemples : Lambert 93 = EPSG:2154 (RGF), EPSG:32631 (WGS84, zone UTM 
31N), EPSG:3857 (WGS84, pseudo-mercator)

4

Source : https://resources.arcgis.com/fr/help/getting-

started/articles/026n0000000s000000.htm

https://epsg.io/La Terre est un géoïde, c'est à dire une 

sphère irrégulière. Pour la représenter, il 

faut trouver un modèle mathématique qui 

corresponde le mieux à la surface 

topographique de la Terre. La surface 

utilisée est donc un ellipsoïde : un volume 

géométrique régulier proche du géoïde.



@ cnes

Installer et configurer QGIS

Installer

https://www.qgis.org/fr/site/forusers/download.html

Configurer

❖ Proxy : 
Préférences > Options > Réseau Configuration proxy

❖ Plugin (Extension) :

Ajout via les dépôts
Extensions > Installer/Gérer les extensions…

Utiliser la barre de recherche ou sélectionner un plugin

Cliquer sur installer

Plugins à installer : ValueTool, ProfileTool, ContrastHomogenizer

❖ Activer OTB

https://gitlab.orfeo-toolbox.org/orfeotoolbox/qgis-otb-plugin
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https://gitlab.orfeo-toolbox.org/orfeotoolbox/qgis-otb-plugin


@ cnes

Ouvrir des données (raster, vecteur) dans QGIS

Pour importer des fichiers dans QGIS, il est possible 

d’utiliser l’explorateur.

❖ Si le panneau n’est pas disponible, l’activer via 

Vue > Panneaux > Explorateur

❖ Double cliquer sur un fichier pour l’importer dans 

QGIS

A savoir que cette méthode permet d’ouvrir n’importe 

quel type de données géographiques 

indépendamment de sa catégorie

Sinon, passer par         puis aller dans la catégorie 

correspondant à la donnée à ouvrir (Raster, Vecteur)
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@ cnes

Ouvrir un flux WMS
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http://maps.theia-land.fr/mapcache_2021/wmts?service=WMTS&version=1.0.0&request=GetCapabilities



@ cnes

Ouvrir un flux XYZ tiles
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http://mt0.google.com/vt/lyrs=s&hl=en&x={x}&y={y}&z={z}

http://a.tile.openstreetmap.org/{z}/{x}/{y}.png



@ cnes

Projection : SCR de la couche et SCR du projet

Chaque couche définit son propre système de 

coordonnées, qui peut être défini ou modifié via le 

panneau de propriétés.

S’il est modifié, les données ne sont pas reprojetées ! 

On ne modifie que les infos de la couche.

QGIS affiche dans un Système de Coordonnées de 

Référence (SCR) qui peut être différent de ceux des 

couches à afficher.

La projection à la volée est une fonctionnalité qui 

permet d'afficher des couches dans un autre SCR que 

le leur, le SCR du projet.
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@ cnes

Rasters – afficher des informations

Avec Value Tool (plugin installé via les dépôts)

❖ Si le panneau du Value Tool n’est pas affiché, 

l’activer via Vue> Panneaux> Panneau ValueTool

❖ Cocher «Enable»

❖ Le plugin affiche les valeurs des bandes de toutes 

les couches visibles sous la souris

Avec l’outil par défaut

❖ Sélectionner la couche

❖ Cliquer sur le pixel souhaité dans l’image
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@ cnes

Rasters - Traitements

Il existe plusieurs façons de lancer des traitements sur 

des couches QGIS rasters :

❖ La calculatrice raster

Raster > Calculatrice raster

❖ La boite à outils

Traitement > Boite à outils

Accès à des outils comme GRASS, OTB…

❖ Le menu raster 

Outils basés sur GDAL qui sont un raccourcis vers 

la boite à outils
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@ cnes

Rasters – afficher des informations

Les outils GDAL sont disponibles dans QGIS

❖ Raster > Divers > Information raster

❖ Sélectionner la layer et cliquer sur ok

Autres

❖ Les outils OTB sont disponibles via la boite de 

traitements

❖ Le plugin profile tool permet d’afficher la valeur 

des pixels d’une bande donnée sous une droite 

tracée à la main
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@ cnes

Vecteurs – afficher des informations

Ouvrir la table d’attributs, cliquer sur Afficher les informations d’une feature
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@ cnes

Vecteurs - traitements

Il existe plusieurs façons de lancer des traitements sur des couches QGIS vecteurs :

❖ La boite à outils

Traitement > Boite à outils

Accès à des outils comme GRASS, OTB…

❖ Le menu vecteur 

Outils écrits en python
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@ cnes

Pour aller plus loin …

Configuration des styles

❖ Choix des bandes d’un raster

❖ Réglage de la dynamique

❖ Transparence

❖ Utilisation de la boite à outils raster

❖ Ombrage 

Export de données

Utilisation des boîtes à outils (OTB notamment)

Création et manipulation de shapefiles

Création de compositions imprimables
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@ cnes

Traitement d’images satellite

16

GDAL (Geospatial Data Abstraction Library) est une bibliothèque libre permettant de 

lire et de traiter un très grand nombre de format d'images géographiques 

(notamment GeoTIFF et ECW) depuis des langages de programmation tels que C, 

C++, C sharp / .Net, Java, Ruby, VB6, Perl, Python, ou encore le langage statistique 

R. Un sous-ensemble de cette bibliothèque est la bibliothèque OGR permettant 

d'accéder à la plupart des formats courants de données vectorielles (à l'exception 

notable d'AutoCAD).

La version binaire inclut de nombreux utilitaires de conversion et de transformation et 

de reprojection pour traiter directement les photos ou les vecteurs.

GDAL/OGR fait partie des projets de la Fondation Open Source Geospatial.

Cette bibliothèque est un des piliers des systèmes d'informations géographique 

libres, car elle permet d'assurer la compatibilité avec de nombreux systèmes 

commerciaux reposant sur des formats propriétaires tout autant que sur les normes de 

l'Open Geospatial Consortium.



@ cnes

Rappel sur les librairies de base python

NumPy

❖ Manipuler des matrices ou tableaux 
multidimensionnels 

❖ Opérer des fonctions mathématiques sur ces 
tableaux

pandas propose des structures de données et des 
opérations de manipulation de tableaux numériques et 
de séries temporelles

❖ Series : stockage des données selon une 
dimension - grandeur en fonction d'un index

❖ DataFrame : stockage des données selon 2 
dimensions - lignes et colonnes, avec des types 
de données potentiellement différentes entre les 
colonnes
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scipy : optimisation, algèbre linéaire, 

statistiques, traitement du signal, traitement 

d'images scipy.ndimage : filtrage, interpolation, 

morphologie (érosion, dilatation), …

scikit-image : traitement d’images (ex. détection 

de contours, débruitage, détection d’objets, 

segmentation, …)

scikit-learn : apprentissage automatique

• Supervisé : classification, régression avec RandomForest, 

GradientBoosting (voir plutôt xgboost), etc.

• Non supervisé : k-means, meanshift, etc.

• Réseaux de neurones

Sans oublier : OpenCV, OTB, et plein d’autres !!!



@ cnes

Traitement d’images raster avec python

Rasterio (https://rasterio.readthedocs.io/en/latest/)

❖ Bien que GDAL offre une API python, celle-ci n’est pas 
commode à utiliser

❖ Rasterio fournit un niveau d’abstraction supplémentaire 
aux couches C de GDAL et se calque sur les structures 
de données numpy

dataset = structure de données permettant d’accéder aux 
métadonnées du raster géoréférencé, et de lire les bandes 
sous la forme de numpy array (ou même masked array)

Traitement :

❖ Avec les librairies nombreuses manipulant du numpy
(scipy, scikit, etc.)

❖ Avec les API de rasterio notamment pour tout ce qui 
concerne les reprojections, le fenêtrage, la gestion 
nodata, l’extraction de features

xarray (http://xarray.pydata.org/en/stable/) + rioxarray

❖ xarray est à Rasterio ce que pandas est à numpy

❖ xarray propose ainsi des tableaux à N dimensions, comme numpy, mais que l’on 
peut manipuler avec des index qui n’ont plus rien à voir avec les indices 
numériques des lignes et colonnes.

❖ La librairie peut de plus lire de multiples fichiers à la fois, comme un seul grand 
fichier. Ou encore manipuler des données ne tenant pas en mémoire.

❖ xarray s’appuie sur Dask pour paralléliser certains traitements et ré-implémente 
plusieurs opérations Numpy dont les opérateurs mathématiques.

Traitement :

❖ Avec les API de xarray
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https://rasterio.readthedocs.io/en/latest/
http://xarray.pydata.org/en/stable/


@ cnes

Traitement de données vectorielles avec python

GeoPandas (https://geopandas.org/)

❖ geopandas = pandas + colonne geometry
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Lecture / écriture de données vectorielles

Traitement

❖ Utilisation des méthodes classiques de Pandas

❖ + API geopandas pour les aspects géographiques 

(reprojection, aggrégation, calcul de centroïd, etc.)

https://geopandas.org/


@ cnes

Machine Learning avec python : scikit-learn
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A quelle classe appartient le pixel ?

Prédire la valeur cible

Chose à diviser selon 

certaines règles

pour améliorer l'efficacité 

de l'apprentissage



@ cnes

Deep Learning avec Python
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Source : https://www.edureka.co/blog/keras-vs-tensorflow-vs-pytorch/


